What's new
Peugeot RCZ Forum

Register a free account today to become a member. It's free! Once signed in, you'll be able to participate on this site by adding your own topics and posts, connect with other members through your own private inbox and take part in competitions!

LOST MY RADIO, JUKE BOX, PHONE, SATNAV..... HELP!

NATSPLATNAT

Member
Joined
Dec 2, 2013
Messages
60
Reaction score
0
Points
6
Location
Kent
Afternoon all you wonderful Z'ers!

I am back and asking for some help .... again. RCZ 2011 GT (pop up display)

A few weeks back my phone stopped connecting to the car... a bit annoying but didn't get round to doing anything about it (standard daily drive for me around 20 min each way) as I thought that as my phone is old it could be that. In hindsight, back in July on a longer journey after around 40mins the system would shut down (screen close the whole works) and I would lose the radio station and the sat nav.... this happened every 20 mins of so (usually right at the point of needing the nav!)

Any way... Drove the car on Sat = radio / screen worked
Went to move my car Sunday pm.... nothing! The whole car totally dead. Managed to jump it. Coming from the centre console was a faint thick sounding ticking noise. Ticking quite fast. Took the car on a drive and had no radio / screen. Radio came back after about 10 mins. No lights on centre console but the air con works!

Monday morning. Dead car... not as dead as Sunday pm, but not enough to start. Jump started it. Noticed same faint, thick sounding ticking noise; ticking about half as fast as Sunday. No radio / screen. The screen does open when you press the button, but nothing on it.... but then it has a meltdown and goes half down and half up before closing.

Battery been fine since - radio hit n miss... ticking noise occasionally.

Relay?
 

Pedro

Active Member
Joined
Jan 16, 2020
Messages
428
Reaction score
162
Points
43
Location
Cheshire
Battery may be knackered as the car is going into "Load Management mode" works in conjunction with "Limp mode" its triggered when not enough power to supply all systems is detected thus it shuts off certain Ancillaries to make sure there is adequate supply to the main ECU BSI modules
The Clicking is poss a relay not having enough juice to the supply circuits its feeding
 

Jumper

Member
Joined
Apr 19, 2019
Messages
50
Reaction score
23
Points
8
As above sounds like a new battery required. If you have a volt meter try testing the battery if its 12v or less with ignition off then its not holding a charge. If you start the car with a voltmeter on it you should see it go from 12 to around 14 volts which proves your alternator is working. Your sat nav is shutting down because your car is trying to cope with low voltage. This can also turn off the Aircon and other things. I'm sure a new battery will get you sorted.
 

NATSPLATNAT

Member
Joined
Dec 2, 2013
Messages
60
Reaction score
0
Points
6
Location
Kent
Thank you for your replies... driving in the dark was fun last night - half my centre console was having its merry little disco.... lights on and off all over the place (oh, and my parking sensors have gone as well!)
I will test my battery this evening. I have it booked into the garage on the 2nd Oct as a back up though (I do have extended warranty), just in case.
 

NATSPLATNAT

Member
Joined
Dec 2, 2013
Messages
60
Reaction score
0
Points
6
Location
Kent
Good morning All,
a quick update - my battery is fine. OH tested it (he's a mechanic) and it is hunky-dory.
Soooo.... thinking caps required me thinks! Any, and all suggestions warmly welcomed! :)
 

Pedro

Active Member
Joined
Jan 16, 2020
Messages
428
Reaction score
162
Points
43
Location
Cheshire
How many Cranking Amps is the Battery throwing out? A battery with dying cells can play up for a day a week or even months
 
Top